Ohhhh jeeee: can't encode a 512 bit MD into a 608 bits frame

Philip Jackson philip.jackson at nordnet.fr
Thu May 21 19:27:55 CEST 2015

On 20/05/15 12:24, Werner Koch wrote:
> gpg tried to verify a key signature and ran into that problem.  Of
> course it should not abort here.  It would be helpful if you can you
> figure out which key causes the problem.  Maybe the key shown last or
> the one which would be shown next.  Running with "--debug 64" might give
> some hints.

Thanks for that Werner.  I found the key causing the problem.  I compared the
output of gpg -k and gpg2 -k and then tried gpg2 --list-sigs on the first key
missing from the gpg2 listing.

The --list-sigs failed with the same 'Ohhhhh jeeeee..." message.

The key ID was 0x6e767393

gpg2 --delete-keys 0x6e767393  also failed and gave the same "Ohhhh jeeee..."
message - that surprised me but the same command with gpg worked ok

Once that key was eliminated from the public keyring, gpg2 -k listing runs to
completion correctly.

And also the keyID which enigmail Key Management would not display, now displays
correctly.  That key was not the one causing the problem. (The problem key had
not been used to sign the key which would not display so I don't understand the
connection between the two events.)

Is it normal that gpg2 would not delete the key causing the problem ?  If that
is so, then we'll need to keep a copy of gnupg 1.xxx for keyring management.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20150521/e2d8c75c/attachment.sig>

More information about the Gnupg-users mailing list