GnuPG modern can't genereate keys on my Windows

Andre Heinecke aheinecke at
Wed Sep 2 13:18:28 CEST 2015


On Monday, August 31, 2015 07:07:03 PM Andre Heinecke wrote:
> If I use the pinentry-basic included in the gnupg-w32 installer I get the
> "No pinentry" error.
> So it looks like pinentry-basic also has a Problem on Windows > 8.1

This was a problem in my test setup. I probably had gpg4win installed when the 
agent was started and so it tried to use the pinentry from gpg4win even after 
I uninstalled gpg4win.

Such things will be solved when gpg4win gets proper 2.1 support. After 
restarting the gpg-agent it picked up pinentry-basic and it worked fine.

If you look at gpg-agent's debug output it will show you which pinentry it 
tries to start.


Andre Heinecke |  ++49-541-335083-262  |
Intevation GmbH, Neuer Graben 17, 49074 Osnabrück | AG Osnabrück, HR B 18998
Geschäftsführer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part.
URL: </pipermail/attachments/20150902/610ae601/attachment.sig>

More information about the Gnupg-users mailing list