gpg2 --version gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.3)

Peter Lebbing peter at
Sat Nov 19 16:36:47 CET 2016

On 19/11/16 15:13, David Adamson wrote:
> Are you proposing I do this every time I wish to use gpg2?
> Is this behavior expected in a successful installation or what did I
> do wrong and can I fix it?

Did you issue a

# ldconfig

as root after you installed the libraries? Because you say you run
Debian jessie, and that has the file:

# libc default configuration

So unless you manually changed the settings for, this directory
should already be in the system search path. However, invoking ldconfig
as root is a necessary step to scan these directories for new additions,
AFAIK. Possibly this is only necessary if you put the first library in
one of the dirs, I don't have the details ready. But in a normal Debian
jessie system, libraries in this directory should "Just Work"(TM).

Or is this a problem with the 1.6.3 receiving priority over 1.7.3? I
don't know off the top of my head how to fix that, so let's try ldconfig



I use the GNU Privacy Guard (GnuPG) in combination with Enigmail.
You can send me encrypted mail if you want some privacy.
My key is available at <>

More information about the Gnupg-users mailing list