configure warnings and errors upon ./configure for Pinentry v0.9.7

David Adamson at
Mon Nov 21 19:51:14 CET 2016

On Mon, Nov 21, 2016 at 12:33 PM, Stephan Beck <stebe at> wrote:
> Hi,
> David Adamson:
> If you only want to use the command line (i.e. text mode) and do not
> need a GUI, you'll probably need the pinentry-curses package. Install it
> by typing: sudo apt-get install pinentry-curses

Thanks for the tip. I just tried your suggestion, installed
pinentry-curses, which installed without error but I am getting the
same error when trying generate keys, just as before.

> There's one thing I don't really understand:
> In your first mail you talked about your laptop with Debian Jessie, and
> that it has gnupg 1.4.18 pre-installed. I think the whole info should
> be: Debian Jessie (standard install) has gnupg 1.4.18 AND gnupg 2.0.26
> pre-installed. Or how would you be able to issue a command gpg2 at all?
> Or do you have a text-mode only pre-installed Debian Jessie with both
> gnupg versions?

You're right there's some information I accidentally left out. I have
a standard debian 8 jessie install which included gnupg v 1.4.18. I
then downloaded and installed from the source code for
version GnuPG modern 2.1.16 and needed libraries. With that said you
can pick up with the opening line of this thread. I hope I didn't
leave anything out this time.

I'm really starting to feel I missed a step along the way and messed
up the install.  I suppose I could do a fresh install  of the OS and
just use the 1.4.18 version otherwise I'm not aware of what to do
differently on my second attempt. I feel as though I followed the
instructions. It probably some basic linux config that I'm too new to
know about, LOL.


More information about the Gnupg-users mailing list