Private Key Encryption

Govenkar, Swetan Swetan.Govenkar at
Tue Oct 4 12:37:40 CEST 2016

Hi Team,

We are performing encryption and decryption process.  We are using the SUSE Linux 11 SPS3 OS. We want to Encrypt and Sign the file using gpg encryption technique.

As a Linux OS root user, we are able to generate keys and perform Encryption, Signing, Verification and Decryption perfectly and we are also able to list the generated keys.

We want to use these keys in the SAP R/3 System. The administrator user for the SAP System is SIDADM. In our case it is SF2ADM.

We switch the user from root to sf2adm and try to generate the keys using the command gpg --gen-key. But we are not able to enter the passphrase for the key. Instead we are getting the error message stating that "gpg: Cancelled by user" "gpg: Key generation canceled."  Please find the attached screenshot of the same.

We have tried the following :

1)Adding a new user home using the command addgnupghome

2)gpg-agent --daemon and setting the link to the requires S-gpg-agent in /tmp/ directory.

3)We thought  the issue was because of terminal type to be set. We have tried setting GPG_TTY to $tty.

But the issue has not been resolved yet.

Could you please let us know what is the procedure to perform encryption and decryption using gpg technique on Linux OS without the root user( Using a different user)

Thanks and Regards,
Swetan G

_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

The information contained in this transmission is confidential. It is
intended solely for the use of the individual(s) or organization(s) to
whom it is addressed. Any disclosure, copying or further distribution is
not permitted unless such privilege is explicitly granted in writing by
PCM, Inc. Furthermore, PCM, Inc. is not responsible for
the proper and complete transmission of the substance of this
communication, nor for any delay in its receipt.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20161004/dccc99f0/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Encryption_Decryption_Error.JPG
Type: image/jpeg
Size: 99312 bytes
Desc: Encryption_Decryption_Error.JPG
URL: </pipermail/attachments/20161004/dccc99f0/attachment-0001.jpe>

More information about the Gnupg-users mailing list