:-(( Re: smart card no longer works

Philip Jackson philip.jackson at nordnet.fr
Sat Sep 10 14:27:50 CEST 2016

On 10/09/16 06:27, NIIBE Yutaka wrote:

> I don't have any experience with this error behavior.  Please describe
> the situation and the interaction; Did you input passphrase and push
> [OK] button, and then gpg failed?
> Please try again with pinentry-curses and/or pinentry-tty.  Does it work?
I don't think the pinentry is the problem. I have tried several versions
and no matter if I enter the pin via dialogue box or on the command
line, the result is the same.

I verified the pin using gpg --card-edit & it is ok.

I think the problem must be more connected with how I introduced my
secring and pubring to the new distro installation when I installed
ubuntu 16.04

I have tried reverting to my old secring.gpg file from before starting
with the smartcard (back in 2014), the one with the full key and not the
'stubs'.  This enables me to run the file decrypt command but of course
I have to enter the old full passphrase rather than the six digit pin of
the smartcard.


More information about the Gnupg-users mailing list