:-(( Re: smart card no longer works

Tristan Santore tristan.santore at internexusconnect.net
Sat Sep 10 14:55:58 CEST 2016

On 10/09/16 14:27, Philip Jackson wrote:
> On 10/09/16 06:27, NIIBE Yutaka wrote:
>> I don't have any experience with this error behavior.  Please describe
>> the situation and the interaction; Did you input passphrase and push
>> [OK] button, and then gpg failed?
>> Please try again with pinentry-curses and/or pinentry-tty.  Does it work?
> I don't think the pinentry is the problem. I have tried several versions
> and no matter if I enter the pin via dialogue box or on the command
> line, the result is the same.
> I verified the pin using gpg --card-edit & it is ok.
> I think the problem must be more connected with how I introduced my
> secring and pubring to the new distro installation when I installed
> ubuntu 16.04
> I have tried reverting to my old secring.gpg file from before starting
> with the smartcard (back in 2014), the one with the full key and not the
> 'stubs'.  This enables me to run the file decrypt command but of course
> I have to enter the old full passphrase rather than the six digit pin of
> the smartcard.
> Philip
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at gnupg.org
> http://lists.gnupg.org/mailman/listinfo/gnupg-users
This sounds like a bit of an issue I had with my Omnikey 38xx. I had a 
similar issue, where it always claimed the pin was wrong. I installed 
the omnikey drivers.... and then restarted PCSD. But I was using the 
pinpad on the device itself. Maybe your issue is different, depending on 
your hardware.


Tristan Santore BSc MBCS
Network and Infrastructure Operations
Mobile +44-78-55069812
Tristan.Santore at internexusconnect.net

Former Thawte Notary
(Please note: Thawte has closed its WoT programme down,
and I am therefore no longer able to accredit trust)

For Fedora related issues, please email me at:
TSantore at fedoraproject.org

More information about the Gnupg-users mailing list