:-(( Re: smart card no longer works

Philip Jackson philip.jackson at nordnet.fr
Tue Sep 20 22:43:17 CEST 2016

On 19/09/16 13:02, Stephan Beck wrote:
>> then run tests. Can now sign and encrypt emails, sign and encrypt and
>> > decrypt files although verify on its own causes me a problem but I
>> > shouldn't think that is connected with the smartcard.
> Another wild guess: maybe it's because the ownertrust values of your own
> public key have not been imported together with the key. You have to
> reassign trust.
> Try
> gpg2 --edit-key [yourkeyID]
> gpg> trust
> 5
> Another way (I forgot to mention this in my previous mail)
> is to import your key with
> gpg2 --import-keep-ownertrust [yourkeyID]
> Then the ownertrust value is being imported as well.

Yes, Stephan, that seems to have solved the issues I had with
verification. The command you suggested does not work as you wrote it -
I got words to the effect that the command was not recognised.

After consulting man gpg2, I tried the following and this worked.

gpg2 --import --import-options keep-ownertrust


More information about the Gnupg-users mailing list