Need help installing 2.1.23

D Mouer wally.twenty.ten at
Fri Aug 25 14:55:44 CEST 2017


I'm currently running Fedora 25 with GnuPG v2.13 installed.
I want to upgrade to v2.1.23 by manually compiling.

I have downloaded:
npth 1.5
libgpg-error 1.27
libgcrypt 1.8
libksba 1.3.5
libassuan 2.4.3


Read the README and INSTALL for gnupg-2.1.23, which instructed to install
the supporting libs in that order above.

Began with npth:
- read the README and INSTALL
- (as sudo, executed:) ./configure, make, make check, make install
- output appeared complete and successfull
- verified the libraries were installed in /usr/local/lib
- other files mentioned were in /usr/local/...

Repeated the process for the next library (libgpg-error),
results appeared ok and checked /usr/local/share/common-lisp/...

Repeated the process again for libcrypt, unfortunately at the end of the
./configure step it gave this message:

     checking for GPG Error - version >= 1.25... no
     configure: error: libgpg-error is needed.
                See .

I thought the previous libgpg-error install succeeded, perhaps not?

How do I proceed at this point?
Can I repeat the build / install process for libgpg-error? Or will it fail
since the files may already be there?
Is there something I need to do to tell libcrypt I have libgpg-error
(>=1.25) installed?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20170825/11201f7d/attachment.html>

More information about the Gnupg-users mailing list