please help "No pinentry"

Bereshka info at
Thu Aug 31 14:20:21 CEST 2017

Hello, Dear Creators :) 

I will very appreciate if you can help me, because I was surfing a lot in the internet looking for an answer, and read tones of forums, but did not find solution.

So I installed gnupg 2 , command gpg didn’t work in Terminal. I was confused and decided to try Gnupg tools suite, I installed that and created my keys and passphrase. Later I knew that I should type gpg2 in Terminal to work with that. So I got encrypted message and I tried to decrypt it, but it just didn’t show a result, it said that by whom it was encrypted and to whom, that’s all. We decided that it might be a problem because go GPG tools suite, maybe it causes conflict. So I decided to deinstall GPG Tools. Before to do that I exported my public, private, rev certificate, then I deinstalled this software. I located all keys to a folder “keys” at my user root folder). Then I imported all keys through terminal. To check I do —list-keys and I see my imported key and my husband’s key that was imported as well. 

1. The problem is that I can encrypt message and send it to him and that he can decrypt it. But when I get encrypted message from him I can’t decrypt it. It does’t ask my passphrase. It asked when I had GPG Tools, but even with asked passpharase with GPG Tools being installed i didn’t get a decrypted message
Now I don’t have GPG Tools and when I do command gpg2 Enter and insert his message I get this 

gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

2. Then, I decided that if there is so much mess with this email, I will create keys with other one , but I still get same error on the step of creation

gpg: public key decryption failed: No pinentry
gpg: decryption failed: No secret key

3. Also I found on one forum that file gpg-agent.conf should be edited with adding this line - pinentry-program /bereshka/bin/pinentry-qt
but it didn’t help


Best regards, 
Anastasiia Gudkov

info at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20170831/36a7c4f0/attachment-0001.html>

More information about the Gnupg-users mailing list