I'm confused about GPG, and it's confused about me

Reid Vail rsv869 at runbox.com
Fri Jan 27 03:25:32 CET 2017

Hello Vedaal -

Sorry if top-posting is bad 'Net manners.

Thank for your reply.  Trying to follow your instructions, really. And not trying to
be too slow to follow.  Below are the steps I took, and the results.

Your suggestions were very straight forward but I couldn't get them to work.  When I
used Seahorse and tried to create a new keypair it never seemed to complete. I know
wants random input and keystrokes to help create the keys.  Tried it several times
but it never succeeded.  I also tried GPA and ran it with the same intent, executed
all kinds of activity to generate random data.  The progress bar in the Generating
Key box completed but I never saw a message that said it completed successfully, and
the new key (if it ever did complete) never showed in the Key Manager screen.

Next I  ran GnuPG manually at the command-line and that did succeed.  I figured I
could manually use that new key to sign the public key was trying send to, which is
the goal.

I executed the following to show the public key I was trying to sign:

rsv2 at rsv2-Serval-Pro ~ $ gpg --with-fingerprint rsv869 at runbox.com_public.asc
pub  2048R/26F66FEB 2016-11-09 Reid Vail <rsv869 at runbox.com>
      Key fingerprint = 3A74 A1DB 2C79 6657 D14B  A6B8 3EDE 6A32 26F6 6FEB
sub  2048R/14C2E935 2016-11-09
pub  2048R/A780EFF6 2017-01-17 Reid Vail (runbox) <rsv869 at runbox.com>
      Key fingerprint = 1F35 6DC3 3182 016A 8E59  E509 9A72 F153 A780 EFF6
sub  2048R/1ED8FE07 2017-01-17

The one I want to sign is A780EFF6.
rsv2 at rsv2-Serval-Pro ~ $ gpg --sign-key rsv869 at runbox.com

pub  2048R/A780EFF6  created: 2017-01-17  expires: never       usage: SC  
                     trust: ultimate      validity: ultimate
sub  2048R/1ED8FE07  created: 2017-01-17  expires: never       usage: E   
[ultimate] (1). Reid Vail (runbox) <rsv869 at runbox.com>

gpg: no default secret key: secret key not available

Key not changed so no update needed.

Next I tried to define it the default key... not happening  !!

rsv2 at rsv2-Serval-Pro ~ $ gpg --default-key A780EFF6 --clearsign REIDgpg

You need a passphrase to unlock the secret key for
user: "Reid Vail (runbox) <rsv869 at runbox.com>"
2048-bit RSA key, ID A780EFF6, created 2017-01-17

gpg: can't open `REIDgpg': No such file or directory

That last is obviously my misunderstanding the command structure, but the man pages
are just a little too opaque for me.... 

Any suggestions are welcome.  


On Mon, 23 Jan 2017 15:36:18 -0500
vedaal at nym.hush.com wrote:

> On 1/23/2017 at 1:00 PM, "reid vail"  wrote:Hi vedaal -
> thanks for your response.  I'll follow those instructions.  
> when you say that's the 'default' key I believe you mean it's the
> default key fore that that specific GnuPG correspondent, right?  And
> by extension, when I import any other public keys I need to sign them
> as trusted (in this case, by Seahorse), as you instructed below.  
> That's the process, I think :->
> =====
> yes.
> also, should you ever need to upgrade to a newer linux system, and
> want to import your keys,
> you would need to first make a keypair in the GnuPg Seahorse or GPA or
> whatever gui you use, in the new system, and then import your keys and
> sign them the the new key
> vedaal

More information about the Gnupg-users mailing list