I'm confused about GPG, and it's confused about me

Peter Lebbing peter at digitalbrains.com
Fri Jan 27 14:16:15 CET 2017

Whoops, left out part of my answer.

On 27/01/17 03:25, Reid Vail wrote:
> When I
> used Seahorse and tried to create a new keypair it never seemed to complete. I know
> wants random input and keystrokes to help create the keys.  Tried it several times
> but it never succeeded.  I also tried GPA and ran it with the same intent, executed
> all kinds of activity to generate random data.  The progress bar in the Generating
> Key box completed but I never saw a message that said it completed successfully, and
> the new key (if it ever did complete) never showed in the Key Manager screen.

I'm sorry to hear you are having such trouble getting it to work! That's
a pretty bad first user experience.

Are you doing this on a virtual machine? Certain virtual machine
deployments have trouble gathering randomness, which prevents generating
keys. Other than that, these programs should just have worked. Odd...

> I figured I
> could manually use that new key to sign the public key was trying send to, which is
> the goal.

I don't fully understand. Are you trying to send someone else an
encrypted document, and are you encountering the situation that GnuPG is
warning you that there is no indication that the key belongs to the


I use the GNU Privacy Guard (GnuPG) in combination with Enigmail.
You can send me encrypted mail if you want some privacy.
My key is available at <http://digitalbrains.com/2012/openpgp-key-peter>

More information about the Gnupg-users mailing list