I'm confused about GPG, and it's confused about me

Reid Vail rsv869 at runbox.com
Mon Jan 30 04:04:47 CET 2017

On Fri, 27 Jan 2017 14:16:15 +0100
Peter Lebbing <peter at digitalbrains.com> wrote:

> Whoops, left out part of my answer.
> On 27/01/17 03:25, Reid Vail wrote:
> > When I
> > used Seahorse and tried to create a new keypair it never seemed to complete. I know
> > wants random input and keystrokes to help create the keys.  Tried it several times
> > but it never succeeded.  I also tried GPA and ran it with the same intent, executed
> > all kinds of activity to generate random data.  The progress bar in the Generating
> > Key box completed but I never saw a message that said it completed successfully, and
> > the new key (if it ever did complete) never showed in the Key Manager screen.  
> I'm sorry to hear you are having such trouble getting it to work! That's
> a pretty bad first user experience.
> Are you doing this on a virtual machine? Certain virtual machine
> deployments have trouble gathering randomness, which prevents generating
> keys. Other than that, these programs should just have worked. Odd...
> > I figured I
> > could manually use that new key to sign the public key was trying send to, which is
> > the goal.  
> I don't fully understand. Are you trying to send someone else an
> encrypted document, and are you encountering the situation that GnuPG is
> warning you that there is no indication that the key belongs to the
> recipient?
> Peter.
> -- 
> I use the GNU Privacy Guard (GnuPG) in combination with Enigmail.
> You can send me encrypted mail if you want some privacy.
> My key is available at <http://digitalbrains.com/2012/openpgp-key-peter>
Thanks very much for your reply, and I completely agree it will be simpler to
outline what I'm trying to do.  It's just this:

I have two email addresses. I'm to send an encrypted message from my gmail
address to my runbox address just to test and to make sure I understand the steps,
and to be sure I have the right tools loaded.

I believe I got turned around because of my really flawed understanding of
the exporting, importing and signing requirements (and because it gets convoluted
when it's your own addresses your working with), and because some of the GUI tools I
have loaded on my Linuxmint 18 KDE implementation aren't working right. 

Here's the output from gpg -K ... Since there are duplicates it might be best delete
them all and start again, with a closer read of the manual.  

rsv2 at rsv2-Serval-Pro ~ $ gpg -K
sec   2048R/26F66FEB 2016-11-09
uid                  Reid Vail <rsv869 at runbox.com>
ssb   2048R/14C2E935 2016-11-09

sec   3072R/709C5420 2016-11-10
uid                  Reid-Gmail <rsv869 at gmail.com>
ssb   3072R/A284EB64 2016-11-10

sec   2048R/A780EFF6 2017-01-17
uid                  Reid Vail (runbox) <rsv869 at runbox.com>
ssb   2048R/1ED8FE07 2017-01-17

sec   2048R/23FFE4EF 2015-10-04
uid                  Reid Vail <rsv869 at runbox.com>
ssb   2048R/385F695B 2015-10-04

sec   2048R/044D3458 2017-01-24
uid                  reid s. vail (GMAIL 1-23) <rsv869 at gmail.com>
ssb   2048R/6A4EDEAB 2017-01-24


More information about the Gnupg-users mailing list