gpg hangs when asking for passphrase

Joey Morris rjmorris.list at
Tue May 9 04:34:35 CEST 2017

I'm pretty new to GnuPG, having installed it a couple months ago for use with
the pass password manager. Everything was working fine until I rebooted my
computer yesterday, and now gpg hangs at the point where I believe it should ask
me for my key's passphrase. For example, the following command hangs:

  $ cat test.encrypted | gpg --decrypt

After several minutes I kill it with Ctrl-C.

I've tried several things without figuring out the problem:

  - Verified that gpg-agent is running with `pgrep -u "${USER}" gpg-agent`.
  - Restarted gpg-agent with `killall gpg-agent`.
  - Verified that the socket referenced by $GPG_AGENT_INFO exists.
  - Ran `export GPG_TTY=$(tty)` in my terminal.
  - Tried several pinentry variants (tty, curses, qt, gtk). Before rebooting,
    I'd been using pinentry-tty without a problem.

A couple other examples of commands that hang:

  $ gpg-connect-agent reloadagent /bye
  $ gpg --edit-key userid

I'm running version 2.1.18 on debian sid. Does anyone have thoughts on what
might be happening or suggestions for additional troubleshooting?


More information about the Gnupg-users mailing list