gpg hangs when asking for passphrase

Daniel Kahn Gillmor dkg at
Tue May 9 18:38:56 CEST 2017

Hi Joey--

On Mon 2017-05-08 22:34:35 -0400, Joey Morris wrote:

> I've tried several things without figuring out the problem:
>   - Verified that gpg-agent is running with `pgrep -u "${USER}" gpg-agent`.
>   - Restarted gpg-agent with `killall gpg-agent`.
>   - Verified that the socket referenced by $GPG_AGENT_INFO exists.
>   - Ran `export GPG_TTY=$(tty)` in my terminal.
>   - Tried several pinentry variants (tty, curses, qt, gtk). Before rebooting,
>     I'd been using pinentry-tty without a problem.
> A couple other examples of commands that hang:
>   $ gpg-connect-agent reloadagent /bye
>   $ gpg --edit-key userid
> I'm running version 2.1.18 on debian sid. Does anyone have thoughts on what
> might be happening or suggestions for additional troubleshooting?

are you using systemd?  do you have dbus-user-session installed?  how
are you logged into the machine (e.g. X11 via gdm, wayland with gdm, a
text-mode-only vt console, etc, ssh session only)?  do you have
libpam-systemd installed?  are you logged into the machine in multiple
concurrent sessions?  does "gpg-connect-agent" on its own hang, rather
than giving you a "> " prompt that you can interact with?  what version
of the debian package are you running?  when you say you've tried
several pinentry variants, how did you try them all?


More information about the Gnupg-users mailing list