gpg hangs when asking for passphrase

Joey Morris rjmorris.list at
Wed May 10 03:43:47 CEST 2017

Thanks for thinking about this, Daniel. Answers to your questions below.

Daniel Kahn Gillmor <dkg at> wrote on Tue, May 09, 2017 at 12:38:56PM -0400:
> are you using systemd?


> do you have dbus-user-session installed?

I didn't at first, but I do now. I saw the hanging behavior both before and
after I installed it.

> how are you logged into the machine (e.g. X11 via gdm, wayland with gdm, a
> text-mode-only vt console, etc, ssh session only)?

X11 via startx. I run openbox-session at the end of .xsession.

> do you have libpam-systemd installed?

Yes. Version 222-1.

> are you logged into the machine in multiple concurrent sessions?


> does "gpg-connect-agent" on its own hang, rather
> than giving you a "> " prompt that you can interact with?

Yes, gpg-connect-agent on its own hangs. (Because I had masked my systemd units
as a workaround, as mentioned in my other email, I unmasked them to reproduce
the hanging scenario in order to test this.)

> what version of the debian package are you running?

Originally 2.1.18-6, and then I upgraded to 2.1.18-7. Same behavior in both

> when you say you've tried several pinentry variants, how did you try them all?

For a couple of them, I edited ~/.gnupg/gpg-agent.conf. For the others, I put
the generic "pinentry-program /usr/bin/pinentry" in gpg-agent.conf and used
Debian's alternatives to specify the preferred variant. In each case, I re-ran
one of the hanging commands after making the change.

I also tried pinentry-gnome3 just now, because I noticed that it's specifically
mentioned in Debian's gnupg-agent README, but it still hangs.


More information about the Gnupg-users mailing list