scdaemon coredumps

Yuriy M. Kaminskiy yumkam at
Wed May 31 02:32:28 CEST 2017

On 31.05.2017 01:48, Daniel Kahn Gillmor wrote:

> On Tue 2017-05-30 15:09:18 +0300, Yuriy M. Kaminskiy wrote:
>> When I tried to rebuild gnupg2 2.1.21-2 debian package from
>> experimental in pbuilder, I got a number of sigsegv's from scdaemon
>> while running tests:
>   [...]
>> (this is on debian jessie, i386, libusb-1.0 1.0.19, and various related
>> libraries from backports [Build-Depends])
> So we're not seeing that crash on the experimental build daemons in
> debian.

Are you *sure*? Testsuite successfully finishes, as if nothing wrong
(and that's probably can be called a bug too); it is only visible by 
noise from kernel in system logs.

 > that makes me think that something is amiss with the
> dependencies in jessie, or maybe we've failed to indicate some
> dependency correctly.

And from first look at sources, it looks like this SIGSEGV is a scdaemon 
bug (and likely an old one), not a missed dependency (FWIW, I looked at 
difference between libusb versions between jessie and sid, I don't see 
anything that can affect this).

What is probably a *new* bug is that gnupg-agent now invokes scdaemon 
(about month earlier, I tried to build gnupg2 2.1.20-3 package, and 
there were no SIGSEGV messages in kernel logs).

> gniibe (cc'ed) is usually the person to sort out scdaemon issues --
> perhaps he can suggest some next-steps for debugging?


P.S. more from debian backports dept: I also noticed that 
npth_1.3-1~bpo8+1 is FTBFS on buildd's:
It seems buildd's for some reason prefers automake1.11 over automake 
(1.14) on jessie. Probably, explicit
Build-Depends: automake (>= 1.14)
would help.

More information about the Gnupg-users mailing list