Cannot control GnuPG from shell (IPC parameter error)

Seby seby2kt14 at
Mon Nov 6 01:59:04 CET 2017

Fixed the problem by killing the PID of gpg-agent and also by
correcting a typo in my syntax that was having a permission problem. I
am now 100% confident that the version mismatch warning between
gpg-agent and gpg is just a warning, it was not the cause of the
problem, the typo in the syntax bares the fault.

Thank you.

 Seby <seby2kt14 at> wrote:
> Hello,
> "NIIBE Yutaka" <gniibe at> wrote:
> Seby <seby2kt14 at> wrote:
>> I am running 2.3.0-beta82. I tried to search for this error and I
>> could only find clues that lead to gpg-agent, but # gpg-agent --help
>> doesn't allow me to disable it. What is the good approach here?
> Please update your installation.
> IIUC, you are talking about (old version of) gpg4win, which is based on
> GnuPG 2.0.x, and you are trying to use new feature(s) of GnuPG 2.2, like
> ECC.
> I am running on linux (Debian) and i am on git master (2.3.0-beta82) and it
> complains:
> WARNING: server 'gpg-agent' is older than us (2.1.8 < 2.3.0-beta82)
> And then:
> IPC parameter error.
> When trying to pass a batch from shell.
> I don't know if the warning causes the second fatal error but probably.

More information about the Gnupg-users mailing list