pinentry problems

Paul H. Hentze paul.hentze at
Thu Apr 19 16:28:21 CEST 2018

On 18.04.2018 22:09, Daniel Kahn Gillmor wrote:
> can you explain the pinentry problem you're seeing?  I'm afraid the bad
> ownership of your files was distracting from any other problems you were
> reporting.
> One simple way to test pinentry (without gpg or gpg-agent in the mix)
> is:
>      echo getpin | pinentry
> that should show you a dialog box that prompts you for a password.  you
> can put in whatever you like, and it should be emitted on the console
> where you ran the above command.
>       --dkg

Okay. I tried your echo and that was fine.
I just copy what I wrote in the emails before, cause this is still the
same problem:

> I tried gpg --gen-key and got even more
>>  gpg: agent_genkey failed: Kein Pinentry
>> Key generation failed: Kein Pinentry
> I went back to the enigmail Troubleshooting advises above under 'How to
> fix it' and tried further, so
> 1. is good
> 2. is good, I made this symlink thing, didn't help
> 3. is good, in my case it's
> pinentry-program /usr/bin/pinentry-qt4
> 4. is good, the gnupg versions are matching
> 5. I don't need this one, because 4 was good, they say
> 6. here is where I get
> ERR 67108949 Kein Pinentry <GPG Agent>
> 7. when I use the normal user and type in
> killall gpg-agent
>  gpg-agent --debug-level expert --use-standard-socket --daemon /bin/sh
> I get
>> gpg-agent --debug-level expert --use-standard-socket --daemon /bin/sh
>> gpg-agent[9469]: WARNING: "--use-standard-socket" is an obsolete
> option - it has no effect
>> gpg-agent[9469]: enabled debug flags: cache ipc
>> gpg-agent[9469]: DBG: chan_4 <- OK Pleased to meet you, process 9469
>> gpg-agent[9469]: DBG: chan_4 -> BYE
>> gpg-agent: a gpg-agent is already running - not starting a new one
>> gpg-agent: secmem usage: 0/65536 bytes in 0 blocks
> I tried it without all unnecessary code above:
> gpg-agent --debug-level expert /bin/sh
> and I get
>> gpg-agent[9477]: enabled debug flags: cache ipc
>> gpg-agent[9477]: DBG: chan_3 <- OK Pleased to meet you, process 9477
>> gpg-agent[9477]: gpg-agent running and available
>> gpg-agent[9477]: DBG: chan_3 -> BYE
>> gpg-agent[9477]: secmem usage: 0/65536 bytes in 0 blocks
> So this debugging doesn't work somehow and there is no other terminal
> window which opens as they say.
> It doesn't work in root either.

So basically, I can activate pinentry, the echo command Daniel send and
the other one from the enigmail site worked well. All graphical windows
are opening when I force it remotely via terminal, BUT I always get this
strange problem that I can't generate keys and I can't decrypt mails.

I didn't attach the graphical message I always get when I want to open a
encrypted message, cause it's too big for this list.
It says "GnuPG can't ask for your passphrase with Pinentry.
This is a failure of the system installation or a configuration mistake,
this is why enigmail doesn't work.
This problem can't be solved automatically."

This is the problem I am still stuck with.


More information about the Gnupg-users mailing list