Issue with pinentry GUI agent

Daniel Kahn Gillmor dkg at
Tue Aug 28 20:22:29 CEST 2018

On Sat 2018-08-25 08:18:48 +0200, sunrises at wrote:
> Hi all, since some days I'm having an issue with pinentry, I've set the default agent as pinentry-qt4
> from update-alternatives (I've also tried pinentry-qt and pinentry-gnome) but when I run gpg --decrypt file
> it's always falling on the cli for prompting the password. In .gnupg/gpg-agent.conf as the first line I have 
> pinentry-program /usr/bin/pinentry-qt4 as well, but I don't get why it's ignoring it.
> There's a way to debug what's going on?

can you give a little bit more information about your system (OS,
version, version of gpg, version of pinentry, etc), and how you're
accessing it (e.g. via ssh, via a graphical environment, etc)?

have you terminated your gpg-agent program ("gpgconf --kill gpg-agent")
after updating your settings in ~/.gnupg/gpg-agent.conf  so that the
settings would take effect?


More information about the Gnupg-users mailing list