Error after secret key list.

Dirk Gottschalk dirk.gottschalk1980 at
Fri Dec 7 00:26:02 CET 2018


Am Freitag, den 23.11.2018, 20:36 +0100 schrieb Werner Koch:
> On Fri, 23 Nov 2018 18:56, dirk.gottschalk1980 at said:
> > I saw the Listing in the debugging log. I tried this also.
> > gpg -k does not show this message, but two messages regarding two
> > keys,
> Hmmm, not easy to debug by mail.
> > gpg: bad data signature from key 2894CD20EE47166D: Wrong key usage
> > (0x19, 0x2)
> That is bug we introduced in 2.2.10 or so which was fixed in
> 2.2.11.  It
> is just wrong diagnostic.
> > Could this be the reason for this error message?
> No.

Thanks to all for your help.

Just to update you: I solved the problem by exporting the public
keyring into a file, deleting pubring.kbx and re-importing the entire

Not to mention that the problem fixed itself automagically. GnuPG
reported one key less as imported than the keyring contained and the
"dead bird" has been gone.


Dirk Gottschalk
Paulusstrasse 6-8
52064 Aachen, Germany

GPG: DDCB AF8E 0132 AA54 20AB  B864 4081 0B18 1ED8 E838

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the Gnupg-users mailing list