Using GnuPG when switching users

Daniel Kahn Gillmor dkg at
Wed Jan 31 23:02:28 CET 2018

On Thu 2018-02-01 09:22:15 +1300, Dan Horne wrote:
> I'd love to have gone to 2.2 but getting GnuPG to work on Solaris is
> extremely difficult. We tried compiling from source, but hit several
> roadblocks. Looking online, several others have reported the same issues,
> but have had no resolution. I messaged this group, but unfortunately, none
> of the suggestions worked.

the only message i see from you about getting gpg to work on solaris is
from back in September:

   Subject: "Insecure memory" (yes setuid set) and "get_passphrase failed"

I don't see any issues about compilation there, though -- sorry if your
messages were missed.

> In the end, our admins found an old packaged version of v2 on an open
> source for Solaris repository. The workaround was to make the virtual
> device terminal of the original user accessible to the su user who was
> creating the keys. This is a security hole that we're not happy with, but
> it was only temporary as we don't require an interactive passphrase
> following key creation.

sounds like a functional workaround for the moment, but it doesn't get
you into the realm of running software with active support :(

aiui, GnuPG *intends* to support platforms like Solaris.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 832 bytes
Desc: not available
URL: <>

More information about the Gnupg-users mailing list