[paperkey] Always output "interrupt"

David Shaw dshaw at jabberwocky.com
Wed Jun 20 13:01:31 CEST 2018

On Jun 20, 2018, at 5:14 AM, Damien Cassou <damien at cassou.me> wrote:
> Hi,
> The output of paperkey is just "interrupt" instead of being a printable
> output. I've tried to use paperkey on 2 different main private keys and
> failed twice. I tried with both the Fedora package and from paperkey's
> source. Same result in every case.
> System:
> - Fedora 28
> - gpg (GnuPG) 2.2.8, libgcrypt 1.8.3
> Keys:
> - key1: ed25519
> - key2: rsa4096
> Command:
> $ gpg2 --export-secret-key "FooBar" | paperkey -vvvv
> interrupt
> $

Hi Damien,

Which version of paperkey is this?  The latest is 1.5 (and support for EdDSA keys was only added in that version), so if you're using an old version can you try the latest?

If that doesn't resolve your problem, can you send me a sample secret key (not your real secret key, of course - just generate a dummy one) that exhibits the problem?  I'll make it work.


More information about the Gnupg-users mailing list