[paperkey] Always output "interrupt"

David Shaw dshaw at jabberwocky.com
Wed Jun 20 21:17:51 CEST 2018

On Jun 20, 2018, at 11:28 AM, Damien Cassou <damien at cassou.me> wrote:
> David Shaw <dshaw at jabberwocky.com> writes:
>> Which version of paperkey is this?
> both the version from source and from Fedora package are 1.5.
>> If that doesn't resolve your problem, can you send me a sample secret
>> key (not your real secret key, of course - just generate a dummy one)
>> that exhibits the problem?  I'll make it work.
> Please find attached the very secret key :-).

I tested this on my regular development box and it worked fine.  Just for completeness, I spun up a Fedora 28 VM and it worked fine there as well.  It occurs to me that given the pipeline you were using, the "interrupt" error may have come from gpg2 rather than paperkey:

> $ gpg2 --export-secret-key "FooBar" | paperkey -vvvv

What happens if you do this:

$ gpg2 --export-secret-key "FooBar" > /tmp/foo.key
$ paperkey < /tmp/foo.key


More information about the Gnupg-users mailing list