Help with "config.h file not found error" on Gnupg version 1.4.13

Robert J. Hansen rjh at
Wed Mar 30 17:48:59 CEST 2022

You will have much better luck if you send only plain-text emails to 
this list.  Some of the people you'd really like to see your email 
refuse to read HTML email, on the grounds that it's a security risk. 
I've quoted your entire message below as plaintext to help you reach 
these people.

To resolve your problem I'd suggest finding where the Automake-created 
config.h header file lies, and including that directory in your GCC 
invocation by using the -I flag.

Hope this helps.  :)

On 3/30/2022 1:21 AM, Francis Kp via Gnupg-users wrote:
> Hi all,
> As in exercise in understanding Cybersecurity in IoT better, I'm trying 
> to implement the flush-reload attack from the paper "FLUSH+RELOAD: A 
> High Resolution, Low Noise, L3 Cache Side-Channel Attack". The crux of 
> the attack is to extract the private key of RSA encryption used in 
> Gnupg. One of the steps to initiate the attack is to find certain memory 
> addresses to feed to a spy function. For that I'm trying to open a C 
> executable in Gnu debugger(gdb). The program is part of the Gnupg 1.4.13 
> version. My aim is to get the memory address of a particular function by 
> setting breakpoint at that line. While compiling the c program using 
> **gcc -g mpi-pow.c**, (And yes I tried without the -g option) I'm 
> getting this error:
> *mpi-pow.c:28:10: fatal error: config.h: No such file or directory
>         28 | #include <config.h>
>            |          ^~~~~~~~~~
>      compilation terminated*
> These were the exact steps I did:-->
>  1.   - Extracted the Gnupg source code using tar xjvf gnupg-1.4.13.tar.bz2
>  2.   - cd gnupg-1.4.13/
>  3.   - ./configure
>  4.   - sudo make
>  5.   - sudo make install
> The source code of Gnupg 1.4.13 is at Link_to_code 
> <>
> The original paper is here Link_to_paper 
> <>
> A quick google search told me that "In computing, configuration files 
> (commonly known simply as config files) are files used to configure the 
> parameters and initial settings for some computer programs". /And as far 
> as I understood, the config file is made when the "./configure" command 
> is run and in this case, it simply means there is no config.h file in 
> the current directory/. There were no errors during the compilation of 
> Gnupg.
> I'm using the Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz processor.
> I tried it on WSL and on Ubuntu 20.04 installed on dual boot.
>   1. What might be the reason ?
>   2. How can I rectify this error ?
> Any help would be highly appreciated.
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

More information about the Gnupg-users mailing list