Fwd: speedo.mk errors out

Christian Sommer code.soma.kurisu at gmail.com
Fri Mar 22 20:14:04 CET 2024

building GnuPG by speedo.mk on current master branch fails. The log
attached for building the dependencies looks fine. But when the configure
tasks starts for building GnuPG itself some requiered libraries (build
artifacts?) couldn't be found. Find the matching config.log attached as
well. This happened on a plane ubuntu 22.04 VM prepared according the
vagrant setup in Build-aux. I tried invoking the build system first with
the native target which lead to the attached logs. Since i haven't yet
scrutined all the relevant code blocks in the build system i just tried
invoking the git-native target as well. But this also faild. Can anyone
point me into the right direction, please?

These are the preparation steps as documented in the vagrant setup script,
just a little modified:
sudo apt-get update -q -q
sudo apt-get install --yes rsync build-essential git gpg automake autoconf
gettext libtool
sudo apt-get install --yes libz-dev libbz2-dev libldap2-dev libsqlite3-dev
libgnutls28-dev libcurl4-gnutls-dev libreadline-dev librsvg2-bin
sudo apt-get install --yes texinfo transfig fig2dev imagemagick file
ghostscript swig doxygen graphviz
sudo apt-get install --yes pkg-config autopoint python-all-dev
python3-all-dev qtbase5-dev
autoreconf -f -i
cd build-aux
make -f speedo.mk native INSTALL_PREFIX=/opt/gpg SELFCHECK=0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnupg.org/pipermail/gnupg-users/attachments/20240322/78f4fb12/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gpg-speedo-build.log
Type: application/octet-stream
Size: 64236 bytes
Desc: not available
URL: <https://lists.gnupg.org/pipermail/gnupg-users/attachments/20240322/78f4fb12/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gpg-speedo-config.log
Type: application/octet-stream
Size: 252613 bytes
Desc: not available
URL: <https://lists.gnupg.org/pipermail/gnupg-users/attachments/20240322/78f4fb12/attachment-0003.obj>

More information about the Gnupg-users mailing list