[gnutls-dev] [Bugs] building 0.9.6 failed on Solaris 8

Nikos Mavroyanopoulos nmav at gnutls.org
Fri May 2 12:59:02 CEST 2003

On Mon, Apr 28, 2003 at 11:16:43AM +0800, Sean Gao wrote:

> Hi, there
>     Recently I have tried to build 0.9.6 on Solaris 8  for times but 
> unfortunately it is always failed.
> I have tried with both Forte 6.0 update2 (cc5.3) and gcc 3.2,  and after 
> correcting some syntax
> checking issues,  the building process always ends with errors when it 
> try to make gnutls-serv in
> the src subdirectory.
>     I have attached the output of bothing building process with this 
> e-mail. I would be very
> appreciated if you could provide me some help on this issue.
This should be because the exported symbols are not correct in 0.8.6.
Try to remove the -export-symbols parameter to libtool from the makefiles,
or use the 0.9.x releases. In linux there was no problem because the exported
symbols are ignored by the libtool (and thus by the linker).

> Cheers
> -Sean

Nikos Mavroyanopoulos

More information about the Gnutls-devel mailing list