[Help-gnutls] What actually works?

Nikos Mavrogiannopoulos nmav at gnutls.org
Sat Jan 21 23:57:55 CET 2006

On Saturday 21 January 2006 22:42, Oliver Lupton wrote:

> I tried installing 1.2.9 on my system, the install was apparently
> successful but I hit the same problems. Everything, including the
> examples and test programs in the tarball, fails with the same error
> as detailed in my first message. I've since moved towards OpenSSL for
> the IRCd module, but I, or a friend working on the same project,
> would be very interested in GnuTLS if we could get anything to work.
> The API is much nicer than OpenSSL's. So is there anything you can
> suggest for why everything is failing as it is? :)

You should note that in the examples there is no error checking.
You should add it in a real world application. In your case I guess the
failure is because you didn't create the certificate and private key 
files.  If you check the code that you attached, a server needs a
certificate and a private key pair in order to work.


More information about the Gnutls-help mailing list