[Help-gnutls] What actually works?

Oliver Lupton oliverlupton at gmail.com
Sun Jan 22 20:42:13 CET 2006

On Sat, 21 Jan 2006 23:57:55 +0100
Nikos Mavrogiannopoulos <nmav at gnutls.org> wrote:

> On Saturday 21 January 2006 22:42, Oliver Lupton wrote:
> > I tried installing 1.2.9 on my system, the install was apparently
> > successful but I hit the same problems. Everything, including the
> > examples and test programs in the tarball, fails with the same error
> > as detailed in my first message. I've since moved towards OpenSSL for
> > the IRCd module, but I, or a friend working on the same project,
> > would be very interested in GnuTLS if we could get anything to work.
> > The API is much nicer than OpenSSL's. So is there anything you can
> > suggest for why everything is failing as it is? :)
> You should note that in the examples there is no error checking.
> You should add it in a real world application. In your case I guess the
> failure is because you didn't create the certificate and private key 
> files.  If you check the code that you attached, a server needs a
> certificate and a private key pair in order to work.
> regards,
> Nikos

Thank you, thank you, thank you! (!!!)
Embarassing now it was something so simple, but it's all working now :)
A million more thanks :)
Apologies if I was a little..accusing in my first emails, it wasn't intentional :)
Thanks again for a great library with an API so much cleaner than OpenSSL's :)



I will live forever, or die trying.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: </pipermail/attachments/20060122/be4100aa/attachment.pgp>

More information about the Gnutls-help mailing list