Problem with session resuming

Nikos Mavrogiannopoulos nmav at
Thu Feb 18 08:39:29 CET 2010

Sebastien Decugis wrote:
> Hello Nikos, all,
> Thank you for your feedback! I just tried with 2.8.5 and got exactly the
> same issue.
> Before going further, let me report a few glintches I got with the 2.8.5
> (retrieved from the tag in git), if it is of interest:
> - it did not compile "out of the box". There was a warning preventing
> the compilation in gnutls_compress.c line 402 about unused label. I
> worked around this one by installing libz-dev (maybe worth adding inside
> the README-alpha list of packages? or adding #ifdef's around the label?)
> - Once I tried to use this new version, I got a "Ohhhh jeeee: operation
> is not possible without initialized secure memory" or something similar
> from my software. After googling a little bit, I added "gcry_control
> (GCRYCTL_DISABLE_SECMEM, NULL, 0);" in my code before calling the
> gnutls_global_init(), along with my other initializers for gcry (that I
> need because of multithreading). Maybe this should be written in the
> GNUTLS manual where examples for multithreading are given (7.2
> Multi-Threaded Applications) ?

This shouldn't be needed unless you call GCRYCTL_INITIALIZATION_FINISHED
in your program. gnutls_global_init() should take care of the functions
you describe. Which version of libgcrypt do you use? (does it fix the
issue if you use the latest?)


More information about the Gnutls-help mailing list