solaris2.6 troubles

Brian Warner warner at
Tue Dec 8 19:29:25 CET 1998

michon at (Emmanuel Michon) writes:
> I noticed prior solaris troubles on the mailing list. I would
> like to report a new one: when running in a xterm or in
> console mode everything runs fine. But when running inside of
> emacs, signing, encrypting won't work, because gpg says it cannot
> open /dev/tty (on a sun, /dev/tty is linked to /devices/pseudo/sy at 0:tty
> but that's not the solution).
> As far as I understand gpg only tries to open /dev/tty to help
> the RNG, so I replaced /dev/tty by another file (quite brutal hack).
> It works now under emacs, but not anymore on the console.

mailcrypt always calls gpg with '--batch' to discourage it from trying to
open /dev/tty (I think /dev/tty is not usable in a program called from an
emacs inferior shell). I haven't tested mailcrypt with 0.4.5 yet, but is it
possible that a use of /dev/tty got added outside of a check for --batch?

/dev/tty is opened during normal interactive use to get the passphrase. But
mailcrypt does other nefarious things to do that non-interactively (it runs
gpg twice: once to find out what passphrase is needed, then again to pass in
the passphrase).

I'll try mailcrypt with 0.4.5 tonight and see if I get the same thing.

  warner at

PS: when running 'make check' on solaris, try editing checks/ to
include "load-extension ../cipher/rndunix" into the "options" file. That will
tell gpg to use the new random module, which should get rid of the "DON'T USE
THIS DATA" and "Oops: no fast poll function" messages (in exchange for
hundreds of lines of new messages about all the exciting random sources
rndunix is taking advantage of). It may still fail some tests (mine is still
running), as the debug messages may trick the test harness into thinking that
errors have occurred (failures on encrypt/decrypt-to-pipe tests are frequently
because of this).

More information about the Gnupg-devel mailing list