BSD/OS 3.1 problems

Werner Koch wk at
Sun Jan 17 19:03:37 CET 1999


Steven said it is okay to forward this to the mailing list.

Any suggestions?


----- Forwarded message from "Steven M. Bellovin" <smb at> -----

To: Werner Koch <wk at>
Subject: Re: gpg 
Date: Sat, 16 Jan 1999 08:35:49 -0500
From: "Steven M. Bellovin" <smb at>

In message <19990116091343.B19544 at>, Werner Koch writes:
>"Steven M. Bellovin" <smb at> writes:
>> I haven't tried running it yet; however, gpg compiles on BSD/OS 4.0 if
>> and only
>> if I specify --disable-asm, and doesn't compile at all on BSD/OS 3.1
>What CPU, can you (or somebody else) look at the assembler code for
>this CPU - maybe it is only a problem with the underscore prepended to
>the function names?

I believe it's the version of the assembler that's being used:

S654$ as -v
GNU assembler version 2.8.1 (bsd/os), using BFD version 2.8.1
^?S655$ gcc -v
gcc version

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include  -g -Wall -O2 -c mpih-mul1.S
/tmp/cc008707.s: Assembler messages:
/tmp/cc008707.s:117: Error: Alignment not a power of 2
/tmp/cc008707.s:135: Error: Alignment not a power of 2
*** Error code 1

>> of strange problems in twofish.c
>Try to replace the -O1 by none and tell me again please.
>  werner
Here was the problem in twofish.c -- there were many more lines like this:

`echo gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../intl  -g -Wall 
ULE -shared -fPIC -lc -o twofish ./twofish.c |  sed -e 's/-O[0-9]*/  /' `
/usr/include/stdio.h:357: warning: `__sputc' defined but not used
twofish.c:2442:invalid character '[' in first operand
twofish.c:2461:invalid character '@' in first operand
twofish.c:2464:invalid character '@' in first operand
twofish.c:2467:invalid character '@' in first operand
twofish.c:2472:invalid character '@' in first operand
twofish.c:2476:invalid character '@' in first operand
twofish.c:2479:invalid character '@' in first operand
twofish.c:29594:invalid character '@' in first operand
twofish.c:29599:invalid character '@' in first operand
twofish.c:29606:invalid character '@' in first operand
twofish.c:29662:invalid character '[' in first operand
twofish.c:29689:invalid character '@' in first operand
twofish.c:29699:invalid character '@' in first operand
twofish.c:29727:invalid character '@' in first operand
twofish.c:29740:invalid character '@' in first operand

s651$ gcc -v
gcc version
s652$ as -v
GNU assembler version 1.38

I confess I don't understand the structure here that involves linking
twofish.c -- if it's something to do with elf-type dynamic linking, it
wouldn't work anyway on BSD/OS 3.1.  

I ran gcc with -E; it produced a rational-looking file, without 29000 lines
or #line entries.  It seems to be the -fPIC that does it; if I delete that,
it compiles just fine.

I should note that I'm not that concerned about 3.1; I'm getting a new machine
in a few weeks and I'll install 4.0 on it, rather than upgrading.  But you
might want to note the problem on your Web page.

----- End forwarded message -----

Koch Softwaresysteme  /  "The GNU Privacy Guard" is an OpenPGP system:
Remscheider Str. 22  /  (
D-40215 Düsseldorf  /
Germany            /  Fingerprint for DSA key <werner.koch at>:
+49 211 3180023   /  ecaf 7590 eb34 43b5 c7cf  3acb 6c7e e1b8 621c c013

More information about the Gnupg-devel mailing list