gpg crashes
Mon, 16 Oct 2000 13:45:15 -0500 (CDT)

I have compiled gpg on sparc Solaris 2.6 using gcc-2.8.1 with the
following configure options:
./configure --enable-m-guard --with-included-zlib --disable-dev-random
--enable-static-rnd=egd --with-egd-socket=/home/buck/.gnupg/entropy

It compiles fine, but when I run gpg --gen-key I get a Bus Error
once it gets to the point where it would actually gen the key after I 
give it my passphrase:

Change (N)ame, (C)omment, (E)mail or (O)kay/(Q)uit? o
You need a Passphrase to protect your secret key.    

Bus Error          

Here is the end of the truss on the process.  The reads are the last
couple characters of the passphrase:

25393:  read(4, " c", 1)                                = 1
25393:  read(4, " k", 1)                                = 1
25393:  read(4, "\n", 1)                                = 1
25393:  ioctl(4, TCSETSF, 0x000ADDA0)                   = 0
25393:  write(4, "\r                      ".., 21)      = 21
25393:      Incurred fault #5, FLTACCESS  %pc = 0x00051530
25393:        siginfo: SIGBUS BUS_ADRALN addr=0x000B18F4
25393:      Received signal #10, SIGBUS [default]
25393:        siginfo: SIGBUS BUS_ADRALN addr=0x000B18F4
25393:          *** process killed ***

Any ideas?

P.S. I tried configuring using diable-asm, but I couldn't even

Mark, Master of the Obvious
	"Why can't the Maples be happy in their shade?"

Archive is at - Unsubscribe by sending mail
with a subject of  "unsubscribe"  to