Follow-up: Using only one public key; no way to sign it

Clint (cpctc)
Fri Dec 7 17:02:01 2001

A few responses suggested the "--always-trust" option; this worked.  Thank
you for your help.

Some responses also suggested the "--trusted-key" option; this sounds better
as it's targeted directly at one particular key, but it didn't work; I'll
make a new post detailing those problems.

----- Original Message -----
From: "Clint (cpctc)" <>
To: <>
Sent: Wednesday, December 05, 2001 2:36 PM
Subject: Using only one public key; no way to sign it

| I want to use gpg with only a single public key.  I know the key is
| and trusted and not compromised, but I can't find a way to tell gpg to
| the key.
| I don't have a private key to sign the public key with, and I don't think
| should need one.
| I've found some relevent posts:
| but nothing since then that's applicable.
| Basically, I want to do the following, starting from a fresh installation
| gpg:
| gpg --import mypubkey.pgp
| gpg --encrypt --recip "mypub" hello.txt
| .. without any user prompts.  The closest I've come is:
| --
| [c:\temp\gpg]gpg --encrypt --recip "mypub" --armor --quiet --batch --yes
| hello.txt
| gpg: abcd1234: no info to calculate a trust probability
| gpg: no valid addressees
| gpg: hello.txt: encryption failed: no such user id
| --
| If I take out the "--batch", I get a prompt:
| --
| Could not find a valid trust path to the key.  Let's see whether we
| can assign some missing owner trust values.
| No path leading to one of our keys found.
| <key info>
| It is NOT certain that the key belongs to its owner.
| If you *really* know what you are doing, you may answer
| the next question with yes
| Use this key anyway?
| --
| I tried "--trusted-key", but it said:
| gpg: key abcd1234: no public key for trusted key - skipped
| so I don't understand what it's good for.
| I'd like the "--strong-yes" or a "--force-trust-key", or a workaround that
| does not require any console input... commands that can all be run
| with --no-tty.
| Thanks.