Can anyone tell me why it is happening (fwd)

Eugene Smiley eugene at
Mon Oct 13 15:43:15 CEST 2003

Hash: SHA1

Atom 'Smasher' wrote:
>> Can anyone point me in the right direction.... I've worked on a
>> project for the last 6-7 months.... it landed on me because the
>> person who originally worked on it was laid off... he was kind
>> enough to give me the password for the key ring. I have been able
>> to decrypt files for the last 6 months with no error messages,
>> however I have now noticed in the last 3 weeks or so that gpg is
>> kicking back an error message to me, "gpg: can't check signature:
>> public key not found". Can anyone tell me why it is happening
>> for the last month?  do I need to get another public DSA key?
> personally, i have little compassion for employers who lay people
> off, so i'm not gonna lose any sleep if they can't decrypt their
> mail while a former employee scrambles to keep food on the table,
> and a roof over their head.

I too "have little compassion for employers who lay people off," but I
disagree with your making this Jeanine's problem. She's probably no
different than the person who was laid off and probably has MORE work
due to the lay off.


Have you recently "clean out" your public keyring by deleting any
keys? You may have deleted the public key that your co-worker set up
to be used to check signatures.

It may also be the case that your public keyring was corrupted. GPG
will create a new keyring in this case and you would need to re-import
the appropriate keys.

Can you give us more details about what you are doing when you receive
the errors?

Version: GnuPG v1.2.2-nr2 (Windows XP)
Comment: Using GnuPG with Mozilla -

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3553 bytes
Desc: S/MIME Cryptographic Signature
Url : /pipermail/attachments/20031013/9cf0456d/smime.bin

More information about the Gnupg-users mailing list