GnuPG Large File Issues - Windows

Jeffrey Tadlock jeffreyt at
Fri Sep 2 18:32:36 CEST 2005

I am hoping to use GnuPG to encrypt some database flat file backups.  My
initial testing worked great, no issues.  However I have started testing
with some slightly larger files - currently 5.7GB in size.  I have tried
it with the default compression on and with a '-z 0'.  The gpg file gets
created with no issues in either case.  When I try to decrypt it though
I get the following error:

gpg: encrypted with 2048-bit ELG-E key, ID C8D07746, created 2005-09-02
      "System Administrator <obscured at>"
gpg: [don't know]: invalid packet (ctb=00)
gpg: WARNING: encrypted message has been manipulated!
gpg: [don't know]: invalid packet (ctb=06)

This happens at the 1.5GB mark every time.

I saw this from the archives:

Has this been fixed in the newer releases?  Or am I missing something

Additional Details:

Running on Windows 2000 SP4

Using GnuPG 1.4.2 (installed via the installer package to c:\GnuPG)

To encrypt I am using this command line:

'gpg --encrypt-files -r "System Administrator" -z 0

To decrypt I am using this command line:

'gpg --decrypt0files <filename_5.7GB_in_size.gpg>'

Any assistance or suggestions would be greatly appreciated!  Just let me
know if I left a piece of information out that you may need.


More information about the Gnupg-users mailing list