pinentry-qt (svn/r153) crashes on exec @ "assuan_register_command"; v0.7.2 execs no error.

Benjamin Donnachie benjamin at
Tue Jan 30 13:39:33 CET 2007

Werner Koch wrote:
> Well, that does not answer my actual question.  I need to know the
> mechanism used to locate the applicatiom bundle.  

I'm not an expert with Mac OS and my understanding is that GUI
applications require an information bundle.  The likes of sh have been
modified to ensure that the bundle is correctly processed and the GUI
information passed to the OS.

Without the bundle information, the application starts beneath all other
applications and cannot grab key focus.  (Search the cocoa-dev and
qt-dev archive for my observations on this).

> Letting the shell decide what pinentry to use is not a good idea -
> we need to be more specific.  In affecting using system() instead
> of fork/exec is in general a bad idea for security reasons.
> exec-ing sh with pinentry as argument is similar to using the
> system() call.

The standard c calls that I tried, and some Mac OS specific ones, did
not read the application bundle information correctly.  Using sh was a
hack; a hack that worked for me that no-one else (apart from less than a
handful of people) were interested in using.

> As I suggested: If you reall realy want to do that you should let
> pinentry re-exex itself.  This way we don't need to change the GnuPG
> code.

I like the idea of having pinentry handle the necessary "magic" to get
things working...  I shall reinvestigate the NSTask Class - it may be
the answer I'm looking for.  (It's been over six months since I last
looked at it).

> Sorry about that but I can't read or follow-up on all mails.  Just
> keep on asking.

I approached the macgpg team too, but at the time gpg2 was alpha-ware
and no-one seemed that interested in getting it all working on the Mac.

I'll see what I can do... but it's a low-priority at the moment.

Take care,


More information about the Gnupg-users mailing list