gpg --gen-key fails with "invalid packet (c2b=2d)" using gpg4win-1.1.1 and XP Pro

Parsavand, Dara dara.parsavand at
Tue Jul 10 23:21:15 CEST 2007

I tried searching this list and found a few others having problems with
key generation, but I haven't figured out the solution for me.  I've
tried downloading GnuPG for windows by itself (gnupg-w32cli-1.4.7.exe)
as well as part of the latest gpg4win package.  Trying to generate a new
key by using GPA gives the following feedback:

   The GPGME library returned an unexpected error.  The error was: 

   General error

   This is probably a bug in GPA. GPA will now try to recover from this

When I run at a Command Prompt gpg --gen-key, I get (after a bunch of
+^.> characters and two messages saying to type to generate random

   gpg: [don't know]: invalid packet (ctb=2d)

I only want to install GnuPG, generate a private key, import a few
public keys, and use gpgee to encrypt and decrypt a few files - I don't
need Outlook integration or anything fancy.  I was a bit surprised to be
shut down so fast.  I have administrator rights (or I couldn't have
installed).  Anything I could be missing?



More information about the Gnupg-users mailing list