Invalid Pin

sysspoof sysspoof at
Sun Jul 29 17:56:11 CEST 2007

 I have a problem with my scard from fsfe.
 I can access the card:
 pgr$ gpg --card-edit
 gpg: detected reader `CCID Smart Card Reader 0 0'
 Application ID ...: D2760001240101010001000007760000
 Version ..........: 1.1
 Manufacturer .....: PPC Card Systems
 Serial number ....: 00000776
 Name of cardholder: Patrick Grieshaber
 Language prefs ...: de
 Sex ..............: male
 URL of public key : [not set]
 Login data .......: pgr
 Private DO 1 .....: [not set]
 Private DO 2 .....: [946] Patrick Grieshaber <pgr at>
 CA fingerprint 1 .: C485 A6CD 7EC6 6E9E EC33  65F2 70F2 75E4 C32F 6CA5
 Signature PIN ....: not forced
 Max. PIN lengths .: 254 254 254
 PIN retry counter : 3 0 3
 Signature counter : 0
 General key info..: [none]
 But if i know want to create subkeys as the tutorials says:
 pgr$ gpg --edit-key Patrick Grieshaber
 gpg (GnuPG) 1.4.7; Copyright (C) 2006 Free Software Foundation, Inc.
 This program comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to redistribute it
 under certain conditions. See the file COPYING for details.
 Secret key is available.
 pub  1024D/2DBAE103  created: 2007-07-14  expires: never       usage: SC  
                      trust: ultimate      validity: ultimate
 sub  4096g/CB84563C  created: 2007-07-14  expires: never       usage: E   
 [ultimate] (1). Patrick Grieshaber (Nickname: Sysspoof) <sysspoof at>
 Invalid command  (try "help")
 Command> addcardkey
 gpg: detected reader `CCID Smart Card Reader 0 0'
 Please select the type of key to generate:
    (1) Signature key
    (2) Encryption key
    (3) Authentication key
 Your selection? 3
 gpg: WARNING: such a key has already been stored on the card!
 Replace existing key? (y/N) y
 gpg: verify CHV2 failed: invalid passphrase
 gpg: error checking the PIN: invalid passphrase
 And i don't know why. I tried the admin pin and the normal/user pin.
I already once tried to write down some subkeys as you see. But unfortunately, the gpg software broke due a segfault :S
 So may the card is corrupt?
 Is there a way to change the pin (?)... i still have the admin pin, also still the default one, i received with a letter from fsfeurope.
Thanks in advance,
Patrick Grieshaber

More information about the Gnupg-users mailing list