Signing eMails doesn't work anymore

Richi Lists ricul77 at
Fri Sep 14 00:02:21 CEST 2012

Now I had a similar problem with debian packages.

That's what I got from dpkg-buildpackage : 

dpkg-buildpackage: warning: Failed to sign .dsc and .changes file
Checking signature on .changes
gpg: no valid OpenPGP data found.
gpg: the signature could not be verified.
Please remember that the signature file (.sig or .asc)
should be the first file given on the command line.
No signature on ./flightpred_0.0.35~precise_source.changes.

I tried both of the following in .bashrc : 
export GPGKEY=E8401492
export GPGKEY=E8401492!

If I try the following manually, then it works: 
gpg --clearsign -u 'E8401492!' flightpred_0.0.35~precise.dsc

The next thing I tried was :
dpkg-buildpackage -kE8401492!
dpkg-buildpackage -k${GPGKEY}

They both work, but that makes me wonder what I set the GPGKEY env var for?


On Di, 2012-08-28 at 10:47 +0200, Werner Koch wrote:
>   gpg --sign -u 'E8401492!' -v
> to force using the first key on your card.
> Salam-Shalom,
>    Werner

More information about the Gnupg-users mailing list