Building Pinentry for Windows

Nikola Radovanovic Nikola.Radovanovic at
Fri Oct 25 13:53:04 CEST 2013


Thanks for reply. I have did all that you wrote in the previous mail. I have dropped the that you attached in the email to the mxe/src folder, but it won't work. 
But, just some moments ago i have successfully built the whole Gpg4Win :), by following the instructions from the README file from the source code. I figured out that the package name for installer is nsis, and not makensis, it is also mentioned in the Basic requirements section of the README file.
Right now, by building the whole gpg4win i have succeeded in what i wanted, but i will certainly try again with MXE to see what is the problem there.

Thanks for your kind responses.
Best regards and cheers to all.

From: Andre Heinecke [aheinecke at]
Sent: Friday, October 25, 2013 9:28 AM
To: Nikola Radovanovic
Cc: Werner Koch; gnupg-users at
Subject: Re: Building Pinentry for Windows


On Thursday 24 October 2013 20:49:09 Nikola Radovanovic wrote:
> 1) When trying to build whole Gpg4Win i ran into several problems. Package
> for gtkhtmlviewer2 couldn't be found, but i have resolved it. This archive
> is now moved to plugins_obsolete folder (instead plugins) on a target url.

Ah, such things happen, i'll see to it that the download url is updated.

> Then stow was not installed on a system, and i have installed it with
> apt-get install stow. But makensis, which is missing, must be installed
> also. And it cannot be installed with apt-get. It requires python, scons,
> zlib and gcc to be installed already, so it is a more complicated process.
> Werner, if you can give me some hints about installing makensis it would be
> great, but anyway i must analyze manual for installing makensis and all
> dependent components in order to proceed further.

makensis is part of the package nsis, which can be installed with "apt-get
install nsis"

> 2) As far as MXE is concerned, i have built and set successfully all
> required packages, and built gcc and qt successfully. And finally when it
> came to build pinentry it failed with message : 'No rule to make target
> 'pinentry'. Stop.' And that's it. I have  downloaded the package and tried
> to build it manually with commands just like in .mk file, but with no
> success.

Yes pinentry is not included in mxe. I have written a .mk file for it and
attached it In my Mail from Wednesday. You should have dropped that file into the src directory of mxe.


Andre Heinecke |  ++49-541-335083-262 |
Intevation GmbH, Neuer Graben 17, 49074 Osnabrück | AG Osnabrück, HR B 18998
Geschäftsführer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

More information about the Gnupg-users mailing list