help with installing a smartcard

Philip Jackson philip.jackson at
Tue Sep 23 14:37:41 CEST 2014

I'm using UbuntuStudio1404.

Working from :

I completed the steps in 2.3.1 using the section "With udev (preferred

I took it that the following stuff under the heading "With hotplug (deprecated
in modern systems)" was a deprecated alternative.  Was this the correct assumption ?

In any case, when I ran the test in 3.1, clearly the system cannot see the card
- I get the following :

gpg --card-status
gpg: selecting openpgp failed: ec=6.108
gpg: OpenPGP card not available: general error

Looking into the directory /etc/udev/rules.d/, I found a README with the following -

"The files in this directory are read by udev(7) and used when events
are performed by the kernel.  The udev daemon watches this directory
with inotify so that changes to these files are automatically picked
up, for this reason they must be files and not symlinks to another
location as in the case in Debian."

so I tried replacing the link created during section 2.3.1 of the howto webpage
with a file.  But the result is the same.

Have I misinterpreted the steps in 2.3.1 ?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 455 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20140923/f4f8a102/attachment.sig>

More information about the Gnupg-users mailing list