help with installing a smartcard

Paulo Lopes pmlopes at
Tue Sep 23 14:49:32 CEST 2014

Hi Philip,

If ubuntu studio 14.04 is like ubuntu 14.04 this is what i did and works
for me, btw this works for me on both ubuntu and gnomeubuntu 14.04 it might
stop working with 14.10 since the init system is switching from upstart to

# Install the card    sudo apt-get install gnupg2 gnupg-agent pcscd
pcsc-tools libccid scdaemon libpam-poldi gpgsm    sudo addgroup
--system pcscd    sudo usermod -a -G pcscd paulo    # gnome keyring
messes up the system    # modify:
/usr/share/upstart/sessions/gpg-agent.conf    ...        eval
"$(gpg-agent --daemon --enable-ssh-support --sh)" >/dev/null
initctl set-env --global GPG_AGENT_INFO=$GPG_AGENT_INFO        initctl
set-env --global SSH_AGENT_PID=$SSH_AGENT_PID         initctl set-env
--global SSH_AUTH_SOCK=$SSH_AUTH_SOCK    end script    post-stop
script        GPG_AGENT_PID=$(echo $GPG_AGENT_INFO | cut -d : -f2)
   kill $GPG_AGENT_PID 2>/dev/null || true        initctl unset-env
--global GPG_AGENT_INFO        initctl unset-env --global
SSH_AGENT_PID        initctl unset-env --global SSH_AUTH_SOCK    end
scriptEdit the file: ```/etc/X11/Xsession.options``` and disable
```ssh-agent```.## Enable gpg agent    echo "gpg-agent" >>
~/.gnupg/gpg.conf## Enable ssh agent    sudo nano
/etc/X11/Xsession.d/90gpg-agentadd the parameter
`--enable-ssh-support` should read:    STARTUP="$GPGAGENT --daemon
--enable-ssh-support --sh --write-env-file=$PID_FILE $STARTUP"##
Disable the gnome keyring daemon for ssh and gpg    cd
/etc/xdg/autostart    mv gnome-keyring-gpg.desktop
gnome-keyring-gpg.nostart    mv gnome-keyring-ssh.desktop

On Tue, Sep 23, 2014 at 2:37 PM, Philip Jackson <philip.jackson at>

> I'm using UbuntuStudio1404.
> Working from :
> I completed the steps in 2.3.1 using the section "With udev (preferred
> installation)".
> I took it that the following stuff under the heading "With hotplug
> (deprecated
> in modern systems)" was a deprecated alternative.  Was this the correct
> assumption ?
> In any case, when I ran the test in 3.1, clearly the system cannot see the
> card
> - I get the following :
> gpg --card-status
> gpg: selecting openpgp failed: ec=6.108
> gpg: OpenPGP card not available: general error
> Looking into the directory /etc/udev/rules.d/, I found a README with the
> following -
> "The files in this directory are read by udev(7) and used when events
> are performed by the kernel.  The udev daemon watches this directory
> with inotify so that changes to these files are automatically picked
> up, for this reason they must be files and not symlinks to another
> location as in the case in Debian."
> so I tried replacing the link created during section 2.3.1 of the howto
> webpage
> with a file.  But the result is the same.
> Have I misinterpreted the steps in 2.3.1 ?
> -Philip
> _______________________________________________
> Gnupg-users mailing list
> Gnupg-users at

Paulo Lopes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20140923/a1eadf48/attachment.html>

More information about the Gnupg-users mailing list