gpg2 --refresh-keys does not talk to dirmngr?

Dirk Gottschalk dirk.gottschalk1980 at
Mon Jul 2 21:22:01 CEST 2018

Hello Werner,

thanks for your answer. The Issue with Proxy was my fault. I didn't
recognize a running dirmngr in background. After I killed this process,
it worked.

Am Montag, den 02.07.2018, 08:40 +0200 schrieb Werner Koch:
> On Fri, 29 Jun 2018 16:12, gnupg-users at said:
> Note that dirmngr has its own Tor support bypassing your proxies.

I'm aware of this. But AFAIK it supüports only connecting to TOR on
localhost. This is not my intention. I have a running server in my
network which rund Suid/Provoxy/TOR. Is it possible to connect to this
tor server on the socks port for doing LDAP, WKD, or DANE Lookups?

AFAIK squid and friends could not do this for me.

> > Is there something I have to set up in one of the configs,
> > especially
> > gpg.conf and gpg-agent.conf?

> No.  It works for me.  You can check this by adding the option 
>   --debug ipc

> to the gpg invocation.  If you don't have a log-file option in your
> gpg.conf the output will go to stderr.

As Told earlier, this Problem is solved. Thanks for your advice.

Dirk Gottschalk
Paulusstrasse 6-8
52064 Aachen
Tel.: +49 1573 1152350
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the Gnupg-users mailing list