make check -> libgcrypt is too old

Jack ostroffjh at
Mon Nov 8 17:28:37 CET 2021

On 2021.11.08 10:54, Christoph Klassen via Gnupg-users wrote:
> I was trying to build GnuPG 2.3.3. For that reason I downloaded and  
> built npth 1.6, libgpg-error 1.43, libgcrypt 1.9.4, libksba 1.6.0 and  
> libassuan 2.5.5 (in this order). Then I started the build process for  
> GnuPG with ./configure and make && make check. One test failed,  
> saying: "t-recsel: Fatal: libgcrypt is too old (need 1.9.1, have  
> 1.8.8)".

Did that happen during ./configure or during make check?  In either  
case, I would check for any left-over remnants of an older install of  
libgcrypt, such as a stray pkcgonfig file.

More information about the Gnupg-users mailing list