[Help-gnutls] can't get libgnutls.so.13 to work

Sam Varshavchik mrsam at courier-mta.com
Fri Jul 10 04:37:53 CEST 2009

cr4yv3n writes:

> Having problems getting gammu to build for Linux. The first time, I got the
> following errors:
> /usr/lib/gcc/i586-pc-linux-gnu/4.1.1/../../../libcurl.so: undefined
> reference to `gnutls_x509_crt_get_dn_by_oid at GNUTLS_1_3'

It would help for you to show the actual link line.

> So, I tried recompiling curl and gnutls. Both built and installed fine. Then


> -rwxr-xr-x 1 root root 507620 2008-09-23 13:11 libgnutls.so.26.4.5

> Says it's there, and yet it STILL doesn't work.

Well, unless the clock on your machine is way slow, if you claim that you've 
just installed gnutls, this isn't what you just installed. "It's" been 
"there" all along, since September of last year.

What's probably happening is that you have multiple, different versions of 
gnutls installed in different directories. Above is the version of GnuTLS 
that was installed by your distribution, and your custom-compiled version of 
GnuTLS probably went into /usr/local.

Having multiple versions of GnuTLS on one system is always a recipe of 
confusion, and mild chaos. It's possible to have multiple versions installed 
in parallel -- I did that for some time -- but this requires a lot of tender 
loving care, and attention to detail.

Don't, whatever you do, try to remove this stuff from /usr/lib.  It's 
probably your distro's GnuTLS. If it gets removed, you may end up with an 
unbootable brick.

Go through your machine, and take a careful inventory of what's where. If, 
as I suspect, your custom-compiled version of GnuTLS is really in 
/usr/local/lib, then if you want to build other software that uses it, 
you'll probably need to add extra compiler flags. Probably "-I 
/usr/local/include" for CPPFLAGS, to pick up the header files, and "-L 
/usr/local/lib -R /usr/local/lib" for LDFLAGS, to pick up the actual 
library. But that's just a guess -- hard to say what's the correct answer is 
for you -- it depends solely on what's really going on in your machine. 
You'll need to do some poking, first.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: </pipermail/attachments/20090709/7a15e83a/attachment.pgp>

More information about the Gnutls-help mailing list