[Help-gnutls] can't get libgnutls.so.13 to work

Brad Hards bradh at frogmouth.net
Fri Jul 10 04:42:41 CEST 2009

On Friday 10 July 2009 12:21:37 cr4yv3n wrote:
> Having problems getting gammu to build for Linux. The first time, I got the
> following errors:
It might help if you explained a bit more about what you are doing. I'm not 
sure exactly which packages / hand-installed versions of which dependencies 
you've used at different times, and that makes it hard to figure out what is 
going on.

> So, I tried recompiling curl and gnutls. Both built and installed fine.
> Then I re-ran ./configure and make and got the same problem. When I try to
> see if libgnutls.so.14 is on my system, I get the following:
> cr4yv3n at Andromeda /usr/lib $ ls -l libgnutls*
> lrwxrwxrwx 1 root root     19 2008-09-23 13:11 libgnutls.so ->
> libgnutls.so.26.4.5
> lrwxrwxrwx 1 root root     12 2009-02-06 18:24 libgnutls.so.13 ->
> libgnutls.so
> lrwxrwxrwx 1 root root     19 2008-09-23 13:11 libgnutls.so.26 ->
> libgnutls.so.26.4.5
To me, it looks like you have two different versions of libgnutls installed. At 
a guess, libcurl is linked against the .so.13 version, but the dynamic linker 
is using the .so.26 version.

> Says it's there, and yet it STILL doesn't work.
Be reasonable. At least describe the error.

Are you sure you have the right paths for the linker? What configure-time 
options are you passing? What environment variables are set?


More information about the Gnutls-help mailing list