[gnutls-help] libnettle still not found

Daniel Kahn Gillmor dkg at fifthhorseman.net
Sat Jul 15 12:22:02 CEST 2017

Hi Max--

On Wed 2017-07-12 10:36:05 +0800, Max Teo wrote:

> I am trying to get windows build version of GnuTLS 3.5.12 working, but no
> matter how amount of playing with cross.mk file, I still can't get it to
> compile successfully.
> I can install nettle 3.1 successfully using
> ./configure --prefix=/usr && make && make install
> But why did cross.mk complain that's not found?
> I retrieve the cross,mk from https://gitlab.com/gnutls
> /gnutls/blob/master/cross.mk
> What am I missing? Can point me in the direction what to check for in the
> system?
> Using Debian Jessie release.
> libnettle2.7 is by default installed and there's no way I could uninstall
> that as it seems that by uninstalling, the OS becomes unusable.

i don't think you need to uninstall it, as the two different versions of
nettle should be able to live side-by-side.

have you tried installing the following packages from the current debian
stable (stretch) directly?

 * libnettle6
 * libhogweed4
 * nettle-dev

or, can you just upgrade to stretch? :)


More information about the Gnutls-help mailing list