make check failed tests

mettodo mettodo at
Fri Jan 22 16:26:24 CET 2021

Hi Bernhard,

I thought I had installed libgpg-error-1.41 properly. I just tried to
install it again and after "make install" I got the messages on the
attached text . 

From what I understand I didn´t get any problem with GnuPG "configure",
you can check the attached text.



On 22/01/2021 12:13, Bernhard Reiter wrote:
> Hi Mettodo,
> Am Freitag 22 Januar 2021 07:02:34 schrieb mettodo:
>> I do not exactly know what you ask for, let me know if this is not enough:
>> - Ubuntu 18.04.5 LTS
>> - gcc version 7.5.0
>> - Attached text with failed checks
> yes, this is a good start to get, so others are able to give you more 
> suggestions.
> As far as I can see, it is all the same error:
> symbol gpgrt_getcwd version GPG_ERROR_1.0 not defined in file 
> with link time reference
> Looks like you may need a newer version of libgpg-error (as far as I can see 
> gpgrt_getcwd was introduced with 1.27 of libgpg-error).
> Did you build libgpg-error yourself? If so, what version?
> The "configure" script should have complained, was it saying okay?
> Best Regards,
> Bernhard
-------------- next part --------------
**libgpg-error-1.41 after make install**

Making install in m4
make[1]: Entering directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/m4'
make[2]: Entering directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/m4'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/m4'
make[1]: Leaving directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/m4'
Making install in src
make[1]: Entering directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
make  install-am
make[2]: Entering directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
make[3]: Entering directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
 /bin/mkdir -p '/usr/local/lib'
 /bin/bash ../libtool   --mode=install /usr/bin/install -c '/usr/local/lib'
libtool: install: /usr/bin/install -c .libs/ /usr/local/lib/
/usr/bin/install: cannot remove '/usr/local/lib/': Permission denied
Makefile:797: recipe for target 'install-libLTLIBRARIES' failed
make[3]: *** [install-libLTLIBRARIES] Error 1
make[3]: Leaving directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
Makefile:1471: recipe for target 'install-am' failed
make[2]: *** [install-am] Error 2
make[2]: Leaving directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
Makefile:1465: recipe for target 'install' failed
make[1]: *** [install] Error 2
make[1]: Leaving directory '/home/mettodo/Downloads/GNUpg/libgpg-error-1.41/src'
Makefile:512: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1

**GnuPG 2.2.27. After running ./configure**

 GnuPG v2.2.27 has been configured as follows:

        Revision:  0c103cde0  (3088)
        Platform:  GNU/Linux (x86_64-pc-linux-gnu)

        OpenPGP:   yes
        S/MIME:    yes
        Agent:     yes
        Smartcard: yes (without internal CCID driver)
        G13:       no
        Dirmngr:   yes
        Gpgtar:    yes
        WKS tools: yes

        Protect tool:      (default)
        LDAP wrapper:      (default)
        Default agent:     (default)
        Default pinentry:  (default)
        Default scdaemon:  (default)
        Default dirmngr:   (default)

        Dirmngr auto start:  yes
        Readline support:    no
        LDAP support:        no
        TLS support:         ntbtls
        TOFU support:        no
        Tor support:         yes

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Gnupg-users mailing list